Auditor is not Tracking Changes

Issue:

Auditor is not tracking changes in SmartList.

Causes:

Cause 1:

The registration keys are invalid. (See Resolution 1)

Cause 2:

Auditor is not installed on each client workstation (including Terminal Server workstation or Citrix workstation) and the server workstation, the builds are not the same on all workstations, or the install process failed. (See Resolution 2)

Cause 3:

Auditor System Tables or SQL Objects are damaged and need to be recreated. (See Resolution 3)

Cause 4:

Users are not tabbing off the changed field. (See Resolution 4)

Cause 5:

The Auditor Group Maintenance window is open. (See Resolution 5)

Cause 6:

The User does not have the appropriate Security settings in Dynamics GP. (See Resolution 6)

Resolutions:

Resolution 1:

Verify the registration keys have been entered and are valid. Go to Microsoft Dynamics GP | Tools | Setup | Auditor | Auditor Setup | Registration. If they are invalid, please follow the steps in this Knowledge Base article:

Registration Keys do not Work for Rockton Products

Resolution 2:

On each workstation, go to Help | Rockton Software Support to verify the version information for Auditor.  You may use the Version Pro tool from our Dynamics GP Toolbox product to show you the version information for all workstations.  If you need to install Auditor, see Knowledge Base article:

Installing a Rockton Software product: First install or installing the latest build/newest version

Resolution 3:

Run the Rebuild process.

  1. Go to Microsoft Dynamics GP | Tools | Setup | Auditor | Auditor Setup.
  2. Click the Troubleshooting tab.
  3. Double-click Rebuild
  4. Mark all 6 check boxes.
  5. Click Process.

Resolution 4:

Be sure the Users tab off of the field they changed in order for Auditor to capture the change.

Resolution 5:

Close the Auditor Group Maintenance window.

Resolution 6:

In order for Auditor to track the changes, it is necessary for all the Users to have the DEFAULTUSER Task assigned to at least one Role that they are in and that the DEDAULTUSER Task must have the appropriate Operations marked.

  1. Go to Microsoft Dynamics GP | Tools | Setup | System | Security Roles.
  2. Select the Role ID that is assigned to the User.
  3. Verify the DEFAULTUSER Security Task ID is marked.
  4. Click Save.
  5. Go to Microsoft Dynamics GP | Tools | Setup | System | Security Tasks.
  6. Select the DEFAULTUSER Task ID.
  7. Select Auditor for Product, Windows for Type, and Series for System. For Dynamics GP 10.0 and later versions, the DEFAULTUSER Task must have these Operations checked:
    • Approvers
    • Auditor Note Maintenance
    • Enter Approver Password
    • E-Sign Approval Needed
    • E-Sign Approvals
    • E-Sign Pending Approval Requests
    • Segregation of Duties Group
  8. Next select 3rd Party for Series. The following Operations must be marked for Dynamics GP 10.0 and later:
    • About Auditor
    • Auditor Setup
    • Code
    • Register Rockton Products
  9. Click Save.

Note:

If the audit is still not tracking changes after checking and/or completing the above steps, please export the Audit Group from the Auditor Group Maintenance window and send it to us at support@rocktonsoftware.com with an explanation of your desired results.

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