Issue
Rockton Pricing Management (RPM) is not calculating prices or is calculating an incorrect price.
Causes
- RPM is not enabled in the ERP.
- The Price Schedule is not active.
- Pricing Mode is not set to the correct Pricing Mode.
- A Price Filter is limiting results.
- Price Schedule does not match existing Price Level or Price Class.
- Price Schedule has an incorrect Rank.
- Price Calculation is set up incorrectly.
Resolution
Resolution 1
Enable RPM within the ERP system you are using.
Acumatica
- Log in to Acumatica as a User with access to the RPM Settings screen.
- Go to Configuration | Common Settings | RPM Settings.
- Verify Enable Rockton Pricing Management is marked.
Dynamics GP
- Log in to Dynamics GP as a User with access to the RPM Company window.
- Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
- Verify Enable Rockton Pricing Management for this Company is marked.
Resolution 2
Mark the Price Schedule as Active.
- Log in to the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Open the Price Schedule the transaction should use.
- Verify the Is Active check box is marked.
Resolution 3
Verify the Pricing Mode being used. If using Dynamic pricing, verify the Price Schedule in RPM is set to Use in Dynamic Pricing. If none are marked, a price would not calculate.
Acumatica
- Log in to Acumatica as a User with access to the RPM Settings screen.
- Go to Configuration | Common Settings | RPM Settings.
- Verify the Pricing Mode selected. If Dynamic is selected, continue with steps 4-6 below.
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Verify the Use in Dynamic Pricing check box is marked for at least one Price Schedule.
Dynamics GP
- Log in to Dynamics GP as a User with access to the RPM Company window.
- Go to Microsoft Dynamics GP | Tools | Setup | Rockton Pricing Management | Company Setup or use the RPM shortcut from the Taskbar.
- Verify the Pricing Mode selected. If Dynamic is selected, continue with steps 4-6 below.
Resolution 4
Check Price Schedule and Price Calculations for Pricing Filters limiting the pricing results.
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Check the Pricing Filter column and check for any Pricing Filters that may be limiting the results.
- From the Pricing menu, click Price Calculations.
- Check the Pricing Filter column for any filters that could be limiting.
Resolution 5
The Price Schedule in the RPM engine must match a Price Level (Dynamics GP) or Customer Price Class (Acumatica).
- Log into the RPM web application.
- Expand the Pricing menu and click Price Schedules.
- Verify the Price Scheduled listed here are also in the ERP.
Acumatica – Receivables | Preferences | Customer Price Class
Dynamics GP – Microsoft Dynamics GP | Tools | Setup | Inventory | Price Level
Resolution 6
More than one Price Schedule was found for the pricing scenario and one has a higher rank than the other. Check the Price Schedules for their ranks.
- In RPM, expand the Pricing menu.
- Click Price Schedules.
- Check the Dynamic Pricing Rank column for the ranks.
Resolution 7
A Price Calculation is set up incorrectly. Check the following.
- The calculation is set as a positive instead of negative.
- It is not marked to modify the unit price.
- From base is or is not marked.
- It is not set to track adjustments.
For more detailed information on issues with Price Calculations see KB Article: Price Calculations are not Calculating as Expected.