User does not have privileges to open this window. Please contact your System Administrator. occurs while using SmartFill

Error:
The following error message appears when you are trying to use SmartFill:

User does not have privileges to open this window. Please contact your System Administrator.

Cause: 
The User does not have the correct security access to the SmartFill windows.

Resolution: 
When SmartFill is installed, all of the windows that an average User needs in order to use the SmartFill product are automatically included in the DEFAULTUSER Security Task.  Therefore, a User must be assigned to at least one Security Role that contains the DEFAULTUSER Security Task in order to access the Dynamics GP windows that SmartFill requires for it to work.

To verify the DEFAULTUSER Security Task is setup appropriately for SmartFill or if you have created a different DEFAULTUSER Task, follow these steps:

  1. Go to Microsoft Dynamics GP | Tools | Setup | System | Security Tasks.
  2. Select the DEFAULTUSER Task ID.
  3. Select SmartFill for Product.
  4. Select Windows for Type.
  5. Select Systems for Series.
  6. Mark the following checkboxes:
    1. Make a Selection.
    2. Select Record.
  7. Select 3rd Party for Series.
  8. Mark the following checkboxes:
    1. About SmartFill.
    2. Calendar.
    3. Code.
    4. Register Rockton Products.
  9. Click Save.

Then verify the DEFAULTUSER Security Task is assigned to the Role that is assigned to the User.

  1. Go to Microsoft Dynamics GP | Tools | Setup | System | User Security.
  2. Select the User and Company.
  3. Mark the Display Selected Roles checkbox.
  4. Double-click on the Security Role ID to open the Security Role Setup window with the Security Role ID selected.
  5. In the Security Role Setup window, verify the DEFAULTUSER Security Task ID is marked.

Note:

Even if a User is assigned to the SMARTFILL ADMIN Security Role, they must also be assigned to a Security Role that contains the DEFAULTUSER Security Task.