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Copyright Manual copyright © Rockton Software, Inc. 
 
Printed in U.S.A. 
 
All rights reserved. 
 
No part of this document may be reproduced, stored or 
transmitted in any form or by any means without prior written 
permission of Rockton Software, Inc. 
 
Unless otherwise noted, all names of companies, products and 
persons contained herein are fictitious and are used solely for 
documentation of this product. 
 

Trademarks Rockton Software® is a trademark of Rockton Software, Inc. 
 
Great Plains® and associated products are trademarks of 
Microsoft® Corporation, Inc. 
 
Crystal Reports® is a registered trademark of Business Objects®, 
Inc.   
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this documentation. 
 

License 
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SOFTWARE LICENSE AGREEMENT 
 

Carefully read all the terms and conditions of this Agreement prior to installing software.  Do not 
activate this software until you have read this entire Agreement.  Installing this software indicates 
your acceptance of these terms and conditions. 

 
If you do not agree to these terms and conditions, then return the software and other components 
of the software package of this product to the place of purchase and your money will be refunded.  
If you downloaded this software in its demonstration form and you do not agree to the terms of 
the license, you may retain the software only in its demonstration form solely for the purpose of 
passing on the demonstration software to another prospective buyer.  No refunds will be given for 
products downloaded off of the Internet that have been registered and activated. 

 
1. LICENSE: You are granted a personal, nontransferable, and nonexclusive, license to use 

the enclosed software, under the terms stated in this Agreement.  Title, copyright and 
ownership of the software and any and all related documentation remains with Rockton 
Software, Inc (Rockton Software).  This software and related programs may be used only 
on a single site licensed for use of Microsoft Great Plains, for the number of concurrent 
users as provided for in the original Microsoft Great Plains Software registration and 
purchase.  Registration keys can be obtained directly from Rockton Software, if 
applicable.  You may not distribute copies of the registered and activated software or any 
of the associated documentation to others.  The demonstration version of the software 
may be distributed freely.  You may not modify, reverse engineer, de-compile, 
disassemble or translate the software or related documentation without the prior written 
consent of Rockton Software, Inc. 

2. BACKUP: You may make backup copies of this software solely for your own use.  You 
must reproduce and include the copyright notice on the backup copies.  If all or any 
portion of this software is included in other software packages, then the copyright notice 
must appear on these other materials. 

3. TRANSFER: You may not transfer this software to any other party.  There are no 
provisions whatsoever for any other transfer, operation, or use of the software by any 
other party whatsoever except for the original buyer of the product that has been 
registered with the Rockton Software at the time of original purchase and software 
activation. 

4. LIMITED WARRANTY: Rockton Software warrants for a period of thirty days (30 days) 
from the date of receipt, that the software covered by this agreement will perform 
substantially in accordance with the accompanying written documentation.  You assume 
the entire risk as to the results and performance of the software.  This warranty gives you 
specific legal rights and you may also have other rights that vary from state to state.  
Rockton Software makes no claim in regard to the merchantability or suitability for any 
specific purpose of this or any other software product. 

5. ACKNOWLEDGMENT: By activating, and using this product you acknowledge that you 
have read this agreement, understand it, and agree to be bound by its terms and 
conditions.  You also agree that this agreement is the complete and exclusive statement 
of agreement between the parties and supersedes all proposals or prior agreements, 
verbal or written, and any other communications between the parties relating to the 
subject matter of this agreement. 

6. REMEDIES: Rockton Software's entire liability and your exclusive remedy shall be at the 
option of Rockton Software, either (a) return of price paid or (b) repair or replacement of 
the software that does not meet the limited warranty and is returned to Rockton Software.  
If you have need of service or help regarding this software, you should contact the dealer 
through which the software was originally purchased.  There is no obligation to render 
assistance to you if you are not the owner under which the software is registered, or if the 
registered user has not purchased a recognized support plan from the vendor of this 
product.  The laws of the State of Washington will govern this Agreement. 
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Introduction  
 
 
Rockton Software is pleased to bring Auditor to the Microsoft Great Plains community.   
 
Auditor is a system management tool to track data changes in your Great Plains or 
Small Business Financials accounting system.  Auditor answers Who changed What, 
When, Where, and optionally, Why.  Auditor can be configured to track field-level 
specific changes, when new records are added, and when information is deleted from 
your system. 
 
Auditor also works with all 3rd party installed products which integrate with Great Plains.  
(Products must be Dexterity based) 

 
For purposes of this manual, Small Business Financials will also be referred to as “Great 
Plains”, as the setup and use of Auditor is the same for both products.  Any instructions 
unique to SBF will be specifically noted. 
 
For purposes of this manual, “Smartlist” will be referenced, even though in Great Plains 
versions 6.0 Smartlist was named “Explorer”.  If you are installing to Great Plains 6.0, 
Explorer is the same as Smartlist.   
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What’s in This Manual 
 
 
This manual contains the basic instructions needed for the installation and use of 
Rockton Software’s Auditor.  You will find instructions for: 
 

• Installation 
• Navigation 
• Setting up Auditor 

 
If you do not find the information you need in the following documentation, please 
contact Rockton Software (see the following page).  
 
 
Symbols and Conventions 
 
To help you use this documentation more effectively, we have included the following 
symbols to highlight important information: 
 
 

���� This symbol points out suggestions and important notes 
that assist you in installing and using Auditor. 
 

���� The warning symbol alerts you to situations in which you 
should proceed with caution.  Notes highlighted with a 
warning symbol relate to information that affects your entire 
system—please read carefully!  
 

���� The “OK” symbol points out helpful tips that can simplify the 
process and save time.  
 

 • Keyboard keys, specific buttons, file names and menu 
paths are shown in bold print, such as the Move Right 
button, the OK key or the setup.exe program.  

 
• Window titles and captions are shown in quotes, such as 

the “Maintenance” window. 
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Customer Technical Support 
 
 
Please contact your authorized reseller for support on this product.  Or, contact technical 
support at Rockton Software by phone at (877) 476-2586 or e-mail 
support@rocktonsoftware.com.  You can also visit www.rocktonsoftware.com for more 
information on Rockton products, including a Frequently Asked Questions section. 

 
User input into improving this product or constructive feedback is greatly appreciated. 
 
If you have registered your Auditor product, support is available depending on the 
support plan agreement you purchased.  Your first line of support should always be your 
Microsoft Business Solutions reseller. 
 
As always, technical ideas and user input is highly encouraged.  At Rockton, we want to 
hear your input.  So drop us a line whenever you feel like it.  Enjoy! 
 
 

mailto:support@rocktonsoftware.com
http://www.rocktonsoftware.com/
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 Installation  
 
 

1. From the first computer you wish to install Auditor, copy the Audit.cnk file 
included in the downloaded or unzipped software into your local Great Plains 
installation folder. 

 
2. Include the new chunk file code by launching Great Plains.   
 

The following message will appear: “New code must be included in the 
DYNAMICS.SET dictionary.  Do you wish to include new code now?” 
Click Yes and a progress bar will display the status of the integrating process 
until the login window appears.  Note that for Small Business Financials, or 
certain versions of Great Plains, this message may not appear. 

 
This process will modify your DYNAMICS.SET file to include information relating 
to the Auditor, and the Audit.cnk file will become an Audit.dic file. 
 

3. Log into the system as the System Administrator using the sa User ID.  This is 
important for building the tables that contain data for the product. 

 
4. Log into any company.  Since Auditor maintains data at the system level, it is 

only necessary to install the software in one company.  If you are evaluating the 
software and do not yet have a registration key, it is recommended that you log 
into the Great Plains test company.  Without a valid registration key, Auditor will 
not work in other companies. 

 
5. You will next be asked how you would like the Auditor windows to be accessed 

within the Great Plains menus.  A dialog will open with the following prompt: 
 

Where would you like Auditor's navigation to appear?  1) do not add Auditor to 
any menu; I will add it myself to the Shortcut Bar, or 2) on the System Setup 
menu, or 3) on the Utilities menu.  Choose "None" if you are unsure. 
 
The dialog will contain three buttons, labeled “None”, “System Setup” and 
“Utilities”, corresponding to each of these three options, respectively.  Whichever 
navigation option you choose will be saved form this point forward. 
 
Note: For users other than ‘sa’ or ‘DYNSA’, no Auditor windows will ever show 
up on any Great Plains menus. 

 
6. Installation is now complete.  Once you register the product, you can install 

Auditor on all other network workstations by following steps 1 and 2 above.  No 
further workstation-specific installation is required. 

 
This completes the process for initial installation.  See the following sections for setting 
system options and maximizing the features of Auditor for your site.  
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Removing Auditor 
 

The following describes the process for manually uninstalling Auditor.  However, note 
that there is now an Uninstall option on the Auditor Setup window.  This will perform all 
of these tasks except for step 2 of the Workstation uninstall below.   
 
Uninstalling Auditor from a Workstation 
 
Perform this process on each workstation where you want to remove Auditor. 
 
1. Edit the Dynamics.set file (located in the Great Plains installation directory) to 

remove the Auditor entries.  There are three steps to this: 
a. The first line in the file should be a number.  Subtract 1 from this number. 
b. Remove these two lines: 

2704 
Auditor 

c. The bottom part of the file contains several path names.  Remove the ones 
that reference the following dictionaries: 

AUDIT.DIC 
FRMS2704.DIC 
RPTS2704.DIC 

 
2. Delete the following files from the Great Plains installation directory (you may not find 

all of these files): 
AUDIT.DIC 
FRMS2704.DIC 
RPTS2704.DIC 
Auditor ReadMe.txt 
Auditor Manual.pdf 
Audit.cnk 

 
 
Uninstalling Auditor From the Server 
 
Perform this process only if you want to completely remove Auditor from the entire 
system. 
 
1. Open SQL Enterprise Manager. 
 
2. Drop all tables in the DYNAMICS database that are named RSAxx, where xx is the 

table number. 
 
3. Drop all stored procedures in the DYNAMICS database whose names start with 

zDP_RSAxxYYY, where xx is the table number. 
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Navigation  
 
 
Because Auditor is designed to be an administrative tool, Auditor windows will only 
appear on the Great Plains menus if you are logged in as ‘sa’ or ‘DYNSA’.  With the 
exception of the system administrator, it is unnecessary for users to navigate to any 
features of Auditor.   
 
When you install Auditor, you will be offered three options from which to access Auditor 
windows.  You can choose to install on the System Setup menu, or the Utilities menu, or 
not to install to any menus at all.  If you choose the latter option, you can add any 
Auditor window to the Shortcut Bar using the procedure described below: 
 

• Open the Shortcut Bar 

• From the Shortcut Bar, press the Add button.  Choose Other Window… from 
the drop down.  

• Select Auditor in the Add Window Shortcut window.  Navigate to the window that 
you want to access and then press the Add button. 

• Press the Done button. 
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An Overview of Setting up Audits 
 
 
Auditor has three methods for tracking data changes in Great Plains: by Window, by 
Table and by SQL Table.  The Window method is the easiest to use, while the Table and 
SQL Table methods are more technical in nature.  Try auditing your system using the 
Window method first.  If you cannot accomplish your auditing goals from the Window 
method, then try the Table or SQL Table method.  At any time you can contact Rockton 
Software or your reseller for assistance. 
 
The Window method allows you to “point and click” on different screens or windows in 
Great Plains.  By using a wizard, you can simply open a window and click on the fields 
you wish to audit.  Auditor will collect the technical information for you, and begin 
auditing your selections. 
 
The Table method allows database administrators to monitor table operations in Great 
Plains.  When a record is added, deleted, or modified, you can track who changed what 
on the record.  An understanding of database structures in recommended for using this 
method. 
 
The SQL Table method also allows database administrators to monitor table operations 
in Great Plains.  However, in addition to auditing Great Plains tables, you can also audit 
Inserts, Updates and Deletes that occur in any table in any database on the SQL Server 
where Great Plains and Auditor are currently installed. 
 
All audits are tracked by a Record Key, which is usually the primary piece of information 
that tracks what has changed.  For instance, if you are auditing employee information 
from the Payroll setup window, the Employee ID would be the Record Key.  If the 
Employee Name changed, you would want to know for which employee the name 
changed, and that would be indicated by the Record Key.  You can choose which fields 
on a window or table to use for the Record Key. 
 
An audit is a logging of a change.  When a field changes, you can either “Audit” that field 
or you can “Audit with Note”.  Notes are helpful when you want users to explain why they 
made a data change.  For instance, if you are auditing employee information, such as 
name, address, and status, you may want to use an audit for name and address fields, 
but place an Audit with Note option on the Department field.  By doing this, when a user 
changes the Department field for an employee, they will be required to enter a note 
explaining the reason for the change.  Notes will be tracked as part of the audit. 
 
You may be tempted to audit everything in your system.  This is not recommended.  
Carefully review the reasons why you want to audit data, and what, specifically, you 
want to audit.  Because an audit is created for every field change (except for the Table 
method) the audit log can grow very large very fast.  An extremely lengthy audit log 
which tracks everything is often useless to anyone. 
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Performance Issues with Auditing 
 
 
Because Auditor has the ability to track so much information, you may want to consider 
that you might encounter performance limitations when using Auditor. 
 
In general, auditing by the Window method shows a non-noticeable effect on 
performance and speed.  Because auditing is done real-time, a small amount of 
processing occurs each time a user enters and exits a field.  Only a very fast typist who 
changes several fields in rapid succession would notice any performance degradation, 
and this is highly unlikely to be noticed at all.   
 
When auditing using the Table or SQL Table methods, it is unlikely that you will 
experience performance degradation unless using a batch process.  If you are auditing a 
table where users are editing one record at a time using data entry screens, the effect is 
not noticeable.  However, if you are posting a batch of transactions, and auditing each 
record, you may notice a slight delay in processing.  For instance, if you are auditing 
deletes on unposted receivables transactions, and you post a batch of 100 transactions, 
a normal processing time of 30 seconds may be increased to 32 seconds.  Again, the 
effect is usually not noticeable, but as the scale of auditing increases you may 
experience a slight degradation in performance.   
 
Most administrative users of Auditor feel the slight performance hit offsets the value of 
the information being collected.  Again, as mentioned above, it is recommended that you 
carefully choose what you want to audit and not simply “audit everything”.  There is a 
performance cost for auditing in any audit system, and you may want to monitor certain 
audits to determine if their speed is acceptable.  In general, performance degradation 
will not be an issue for most users of Auditor. 
 
 

 
 



Rockton Software Auditor, 4/9/2009    13

About Auditor window 
 
 

 
 

 
This window is accessible in one of these ways, depending upon what you opted when 
you first installed Auditor: 

• From the Shortcut Bar. 
• Go to Help > About Microsoft Business Solutions-Great Plains…  From the 

Extras menu, choose Additional > About Auditor. 
• Go to Tools > Utilities > About Auditor 

 
 
Description 
 
The About Auditor window shows the version of Auditor that you have loaded, along with 
the phone number to use to contact Rockton Software, and a link to our website.  In 
addition, it also provides a convenient means of navigating to the Auditor Registration 
window. 
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Auditor Registration window 
 
 

 
 

This window is accessible in one of these ways, depending upon what you opted when 
you first installed Auditor: 

• From the Shortcut Bar. 
• Go to Help > About Microsoft Business Solutions-Great Plains…  From the 

Extras menu, choose Additional > About Auditor.  Then choose the Register 
button. 

• Log on as the System Administrator (‘sa’) and go to Tools > Setup > System > 
Auditor Setup.  From the drop-down, choose Registration and choose the 
Process button. 

• Log on as the System Administrator (‘sa’) and go to Tools > Utilities > Auditor 
Setup.  From the drop-down, choose Registration and choose the Process 
button. 

 
 
Description 
 
The Auditor Registration window is where you enter your Registration Key.  After 
entering your key, just tab off the Registration Key field.  If your key is valid, a “Thank 
You” message will be displayed.  If not, you will see the words Key is Invalid to the right 
of the Expiration Date.   
 
If you are told that your keys are invalid, first verify that you have not mistyped anything.  
If you received your keys in an email, it may be helpful to copy the keys from the email 
and paste them into the Registration Key field to avoid typing mistakes.  If you still see 
this message, contact Rockton Support to verify that your Site Name, User Count and 
Great Plains version have not changed since you got your keys.  If necessary we will 
generate new keys and resend them to you. 
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Auditor Setup window 
 
The Auditor Setup window allows you to perform setup and maintenance tasks. 

 
This window is accessible in one of these ways, depending upon what you opted when 
you first installed Auditor: 

• From the Shortcut Bar. 
• Log on as Sys Admin (‘sa’) and go to Tools > Setup > System > Auditor Setup.   
• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.   

 
Description 
The task drop-down is used to select which task you want to perform.  Once you have 
selected a task, choose the Process button.  The tasks available are described below: 

Install/Upgrade Auditor Installs or upgrades from a previous version.  It will also 
install Smartlist objects, and will set table permissions to 
all users in the system database.  This may take a few 
minutes.  You can perform this task multiple times. 

Registration Opens the window where you enter the registration key. 
Add Smartlist Objects If you have removed the Audits object from SmartList, 

you can add it back by performing this task. 
Remove Smartlist Objects Removes the Audits object from SmartList. 
System Settings Opens the window where System Administrators and 

other system settings are managed. 
Integrity Check Run this process to verify the integrity of your audit 

setups.  A report will inform you of any discrepancies. 
Audit Log Maintenance Opens the purge utility to maintain your system audit log. 
Rebuild SQL Triggers Drops and re-creates all SQL Triggers associated with 

SQL Table audits that you have defined. 
Rebuild SQL Tables Master Recreates the list of tables and databases in the SQL 

Tables lookup on the Groups Maintenance window. 
Auditor Debugger Rockton tech support may ask you to go to this window. 
Uninstall Auditor Tables will be removed from the database, the Audits 

object will be removed from Smartlist, and Auditor will be 
removed from the launch file. 
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Group Maintenance window 
 
This is where you manage audits that are alike or based on an area in the system.  

 
How you access this window depends upon what you opted when you installed Auditor: 

• From the Shortcut Bar. 

• Log on as Sys Admin (‘sa’) and go to Tools > Setup > System > Auditor Groups.   
• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Groups.   

Description 
You may want to have a Group for Receivables, and another for Payables.  You can 
have an unlimited number of Forms or Tables in a Group.  Once a Group is configured, it 
can be exported to a text file to be sent to another site to be Imported using this window.  

Use the Add , Edit and Delete buttons to modify the Forms or Tables for a group. 

The Companies and Users features limit audits in this Group to specific companies or 
users.  By default, a new Group will work for all companies and all users.  Also, 
Company and User information is NOT imported or exported.  

A given Table or Form can belong to one and only one Group.  Therefore, how a Form 
or Table is audited can only be set up one way across all companies and users. 

Auditing by SQL Table tracks changes in any table/database on the server where Great 
Plains and Auditor are installed, including tables that are not related to Great Plains. 
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Auditor Form Maintenance window 
 
Auditor Form Maintenance is where you select the fields that you want to audit, and how 
you want to audit them.  The fields are organized by window. 
 

 
 
To get to this window, first open the Group Maintenance window while you are logged on 
using the System Administrator (‘sa’) account.  Then double-click one of the forms listed 
in the Forms list box. 
 
Description 
A Form is a “container” for windows, and often a form contains one window with the 
same name as the form.  When you select a Window, its fields will list on the right side.  
By selecting a field, you can mark that field as a Key Field, Audit, or Audit with Note.  An 
icon will appear next to the field designating its purpose.  A field can not be audited if it is 
a Key Field.   

The easiest way to set up a window to be audited is by using the Field Selection Wizard, 
located at the lower left of the window.  Press this button to start the Wizard. 
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From the Wizard window, press Open Window to open the window you are Auditing. 

With this window is open, press the Key, Audit, or Audit w/Note buttons to enter the 
“mode” of field selection.  Once you are in a “mode”, click on the window fields you want 
to set to this mode, and they will automatically collect in the Wizard window. 

When you are finished, close the window.  Then press the Finish button on the Wizard.  

You can manually review which fields can be audited on a window by reviewing the list 
of fields on the right of the Auditor Form Maintenance window.  The tree to the left will 
list the form at the top, and all of its windows beneath it.  Selecting the form on the left 
will display all audited fields from all windows on this form on the right.  Selecting a 
window on the left will display all fields on that window to the right, whether or not they 
are part of an audit. 

You can choose useful options for each field that you audit.  Select a field in the right list, 
and then press the Field Options button.  The following window will appear: 
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The following Options are available for auditing. 
 
Send an Email to the System 
Administrator 

Choose this option to send an email to the System 
Administrator email specified in the System Setting 
setup window. 

Send an Email to this Alternate 
Address 

Choose this option and specify an email address to 
send a specific person a notification of an audit on this 
field. 

Use an Alternate Display Field 
Name 

You can specify a more useful name for a field than 
what is defaulted in the system to appear in the Audit 
Log.  For instance, a field may be called “User Defined 
1” and in your setup that field may track “Customer 
Status”.  You can specify the alternate field name here 
and the Audit Log will show the alternate name 
instead. 

Add Decimal this Many Places 
from the Right 

Great Plains tracks currency fields with misleading 
decimal places.  For instance, $98.00 might be tracked 
as 9800 when audited.  By putting a 2 in this field, the 
9800 will be recorded as 98.00. 

Filter Predefined Notes to this 
Reason Group 

Once you have Reason Groups defined, you can 
assign a specific group to display in Note Entry for this 
audit field. 

Do Not Track Blank to Non-
Blank Changes 

It is sometimes useless to audit a field that changes 
from blank to a valid value, which often occurs when 
entering data for the first time.  Use this option to 
exclude audits of blank to non-blank values. 

Use Field Mapping Often times lists, radio buttons, or checkboxes appear 
as numbers instead of useful descriptions.  For 
instance, SOP Entry has an SOP Type that when 
audited appears as the numbers 1 through 5.  You can 
map the value “1” to “Quote” and “2” to “Order” so that 
the audit log reflects more useful data. 

Use Conditional Auditing Choose this option to make an audit conditional.  The 
condition listed must be true in order for an audit to 
occur.  Specify the comparison field, the operator 
(equal or not equal) and the string value to compare 
the field to.  If this expression evaluates to true during 
auditing, and audit will be captured. 
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Auditor Table Maintenance window 
 
Auditor Table Maintenance is where you select the fields that you want to audit, and how 
you want to audit them.  The fields are organized by table. 
  

 
 
To get to this window, first open the Group Maintenance window while you are logged on 
using the System Administrator (‘sa’) account.  Then double-click one of the tables listed 
in the Tables list box. 
 
 
Description 
 
You can select specific fields and/or table operations to audit.  For each field selected, 
you may specify the same options that are available for window fields.  The field list can 
be sorted by the column headings.   
 
For adds or deletions from the table, you may also specify these options, as well as 
requiring that the user enter a Note.  For changes to the table, you may specify that the 
audit will only take place after a certain amount of time has elapsed.   
 
All of these options are described in the tables below: 
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Option Explanation 

 
Track Added Record Check this option if you wish to audit when users add 

records to this table. 
Require Note If Track Added Record or Track Deleted Record is 

selected, you can require a Note to be entered for the 
user to explain why they added or deleted the record. 

Add/Delete Options On a table operation of Add or Delete, you can specify 
options on that audit, such as emailing a notification or 
specifying conditions on when to audit.  Pressing this 
button will open the same Field Options window that is 
used above in Form Maintenance.  Keep in mind some 
options are not valid for Additions and Deletions of 
records. 

Track Deleted Record Check this option to track deletions of records from this 
table. 

Track Edited Record Check this option to track specific field-level changes 
(which also must be selected in the field list below).  You 
can also optionally choose to track edits only after a 
certain number of hours of adding a new record.  This is 
useful in case you are not tracking new records, and it is 
likely that insignificant edits will be made in the first few 
hours of a new record being added. 

 
The following options are available for each field in the field list: 
 

Column Explanation 
 

Ref Use this column checkbox to mark a field or fields which represent 
the Primary Key or primary data element(s) that makes records in 
this table unique to track.  For instance, the customer table has a 
Primary Key of Customer Number.  These reference fields are 
used to track specific records in the audit log, so choose them 
carefully.  When in doubt, choose the same fields indicated 
with an asterisk as the Primary Key. 

Audit Mark the fields for which you wish to track changes.  Only the fields 
marked will be audited. 

Note When a field is audited, you can optionally check the Note 
checkbox to force a user to explain why a field was changed.  
Users are prompted with note entry after they modify a record if 
this box is checked.  The user can close the note window, but they 
will be prompted repeatedly until they complete the notes. 

 
When you have completed specifying what to audit, click the OK button.  Auditor will now 
audit the tables and fields you have set up. 
 
Also, for any given field in the list, you can choose Field Options to set up advanced 
auditing features.  See the Field Options window as explained above with Form 
Maintenance for more details. 
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Auditor SQL Table Maintenance window 
 
Auditor SQL Table Maintenance is where you select the fields that you want to audit, 
and how you want to audit them.  The fields are organized by table. 
  

 
 
To get to this window, first open the Group Maintenance window while you are logged on 
using the System Administrator (‘sa’) account.  Then double-click one of the tables listed 
in the SQL Tables list box. 
 
 
Description 
 
You can select specific fields and/or table operations to audit.  You can also select 
whether or not you should audit if the user is changing a field from blank to some value.  
The field list can be sorted by the column headings.   
 
All of these options are described in the tables below: 
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Option Explanation 

 
Track Added Record Check this option if you wish to audit when users add 

records to this table. 
Track Deleted Record Check this option to track deletions of records from this 

table. 
Track Edited Record Check this option to track specific field-level changes 

(which also must be selected in the field list below). 
 
The following options are available for each field in the field list: 
 

Column Explanation 
 

Ref Use this column checkbox to mark a field or fields which represent 
the Primary Key or primary data element(s) that makes records in 
this table unique to track.  For instance, the customer table has a 
Primary Key of Customer Number.  These reference fields are 
used to track specific records in the audit log, so choose them 
carefully.  When in doubt, choose the same fields indicated 
with an asterisk as the Primary Key. 

Audit Mark the fields for which you wish to track changes.  Only the fields 
marked will be audited. 

No Trk Blnk It is sometimes useless to audit a field that changes from blank to a 
valid value, which often occurs when entering data for the first 
time.  Use this option to exclude audits of blank to non-blank 
values. 

 
When you have completed specifying what to audit, click the OK button.  Auditor will now 
audit the tables and fields you have set up. 
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System Settings window  
The Auditor System Settings window allows you to manage System Administrators. 

 
This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as System Admin (‘sa’) and go to Tools > Setup > System > Auditor Setup.  Then 

choose System Settings and then the Process button. 
• Log on as System Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.  From the 

drop-down, choose System Settings and choose the Process button. 

Description 
This window lets you specify which users in your system are System Administrators.  
The only reason to be listed as an Administrator is so that you can be notified when the 
Audit Log reaches a specified threshold.  It is optional to use this feature. 

If you check the “Warn System Admins when log records exceed” checkbox, enter the 
number of records acceptable in the log file before being notified.  We recommend about 
10,000 records to start with.  If this option is checked, then any user marked above as a 
System Administrator will, upon logging into Great Plains, receive a warning message 
notifying them that the log has exceeded this limit. 

“Allow editing of Audit Notes” lets users edit their notes in the Audit Inquiry window.  
Open the Audit Inquiry window from SmartList by double-clicking an audit.  By checking 
this box, users can edit their notes in the future rather than being limited to Note Entry.   

The System Admin email address is the one email or alias used for audits that are 
marked with the option of “Send an Email to the System Administrator”. 

“Do Not Encrypt SQL Triggers” may be used when working with Rockton Support.  
Under normal circumstances you will leave this box unchecked. 

“Do not allow SQL Table audits on non-GP databases” will cause the “Rebuild SQL 
Tables Master” process to exclude all databases except the DYNAMICS database and 
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all company databases used by Great Plains.  These will then be the only databases 
that show up in the list when you attempt to add a SQL Table audit. 

“Do not allow SQL Table audits on SQL system databases” will cause the “Rebuild SQL 
Tables Master” process to exclude the master, model and msdb databases.  These 
databases will not show up in the list when you attempt to add a SQL Table audit. 

Tables in the tempdb database will always be excluded from this list and therefore will 
not be available for SQL Table audits. 

Reason Codes window 
The Reason Codes window is where you set up common reasons for making changes in the 
system.  These reason codes can then be used in the Note Entry window. 

 
This window is accessible in one of these ways, depending upon what you opted when you first 
installed Auditor: 

• From the Shortcut Bar. 
• Log on as Sys Admin (‘sa’) and go to Tools > Setup > System > Auditor Reason Codes.   
• Log on as Sys Admin (‘sa’) and go to Tools > Utilities > Auditor Reason Codes. 

Description 
Reason Codes are predefined notes that are common reasons for making changes in 
the system.  For instance, changing an employee last name is often due to marriage or 
court decree.  You may want to preset the reasons in a list so users can quickly choose 
a reason during note entry without having to type it in. 

Reason Groups allow you to package several notes together and filter them on a specific 
audit.  For instance, you may have three reasons for a name change on employees, but 
you may have six reasons why a credit memo was issued.  The reasons that appear in 
one audit situation don’t make sense in another.  By grouping these two sets of reasons 
into two groups, you can make Note Entry more useful by specific which Reason Group 
is to be used on an audit.  This is specified in the Options for a field audit.  During Note 
Entry, only those notes in the group which are related to the audit will be listed. 

You can create a new group by pressing the New button to the right of the Reason 
Group field.  Likewise, you can delete a group by pressing the Delete button. 
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Enter a reason in the Note/Reason box, and then Insert it into the list.  You can also 
highlight an entry in the list, then edit its text and press Replace.  Finally, you can 
remove a specific reason by highlighting it in the list and pressing the Remove button. 

Note Entry window 
This window is where the User enters the reason for making any change in the system that has 
been set up to require a note. 

 
This window will open automatically whenever the User makes a change to a field that has been 
set to Audit w/ Note.  See the descriptions of the Auditor Form Maintenance and Auditor Table 
Maintenance windows above for more information about how to set up this type of audit. 

Description 
If you choose to audit a field and require a note, upon logging that audit the Note Entry 
window will appear.  It will specify the details of the audit, and instruct the user, in bold, 
to enter the reason that they made the change. 

Pressing the Details button will show the Audit Inquiry window for more information. 

The user can enter a Note or Reason by typing in freeform text into the note field, or by 
choosing a predefined note from the drop down list.   

It is possible for users to press OK and not enter a note or reason as required.  
However, Auditor has a “nag” feature, and each time the user logs into Great Plains, un-
noted audits will reappear.  So the user will be forced to eventually deal with the notes, 
but may choose to dismiss the note entry if time is not available at the moment of audit. 

The Note Entry window will display a status bar in the lower left explaining how many 
audits are left to be noted.  Use the Previous and Next buttons to see different audits as 
applicable.  When all notes are completed, press the OK button. 
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Audit Log Maintenance window 
 
 
This window is where you can purge or archive old, unnecessary Audit Log records. 
 

 
 
This window is accessible in one of these ways, depending upon what you opted when 
you first installed Auditor: 

• From the Shortcut Bar. 
• Log on as System Admin (‘sa’) and go to Tools > Setup > System > Auditor 

Setup.  Then choose Audit Log Maintenance and then the Process button. 
• Log on as System Admin (‘sa’) and go to Tools > Utilities > Auditor Setup.  From 

the drop-down, choose Audit Log Maintenance and choose the Process button. 
 
Description 
 
The system Audit Log is the physical table RSAS015 in the DYNAMICS database.  Over 
time, this log can grow quite large.  You can use the System Settings panel to specify a 
warning to be issued to system administrators when a specified threshold is reached. 

The purpose of the Log Maintenance window is to permanently archive and purge the 
log file.  You can follow the on-screen steps in order to determine how many records are 
in the log file, and then define a query to select records for purging. 
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Pressing the Define button will open an interactive tool for defining a query to act on the 
log file.  You can filter which records you want to archive using this tool.  If you need help 
with this feature, please contact us or your reseller for support. 

It is recommended that you export the records to xml using step 4 or performing a 
backup and permanent archive of the DYNAMICS database before purging the log. 

Once you press Purge Selected Records, the selected records will be deleted from the 
log file and cannot be recovered without a proper restore. 

  
Audit Reporting using SmartList 

 
You can use SmartList to view the Audit Log.  
 

 
 
To get to this window, go to View > SmartList, or simply press the SmartList icon on the 
Microsoft Great Plains toolbar. 
 
Description 
 
All system audits are tracked in a single table in the system database, and can be 
reported using Smartlist.  Smartlist is the only built-in way of directly viewing audits.  
Using the features of Smartlist, you can filter and sort your audits and export them to 
Word or Excel for further evaluation.  The Audits object appears automatically in 
Smartlist after the product is installed. 

For more technical reporting of audits, you can access the audit table directly in SQL 
system by querying the table RSAS015 in the DYNAMICS database. 
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