The Install/Upgrade Window Continues to Appear When Logging into GP after Installing the Latest Build of SmartFill

Issue:

After installing the latest build of SmartFill, the Install/Upgrade Wizard window continues to appear when users log into Dynamics GP.

Cause:

This will happen if the latest build for SmartFill was not installed on all workstations that currently have SmartFill installed.

Example:

SmartFill 16.0.2 was installed on workstations A and B, but it was not installed on workstation C which is still on 16.0.1. When a user logs onto workstation C, they receive a message saying that they need to update SmartFill because the server (table SF005) identifies they should be on Version 16.0.2. Before downloading and installing SmartFill for Dynamics GP 2016 to workstation C, the user runs the Installation Wizard, which sets the SF005 table field value back to Version 16.0.1. Now, when users log into workstations A or B, they receive the message asking them to update because the server identifies they should be on Version 16.0.1. This loop will continue until SmartFill for Dynamics GP 2016 is downloaded and installed on workstation C.

Resolution:

Install the latest build on all workstations with SmartFill. To see which workstations still need SmartFill installed, once you are logged into GP, go to one of the following windows:

  • SmartFill Setup:  Go to  Dynamics GP | Tools | Setup | SmartFill | SmartFill Setup.
  • SmartFill Registration:  Go to Dynamics GP | Tools | Setup | SmartFill | SmartFill Setup and then click Registration.

To see what version the server table (SF005) has in it, go to the following window:

  • Rockton Software Support: Go to Help | Rockton Software Support.

To install SmartFill, follow the steps in Knowledge Base article: Installing a Rockton Software product: First install or installing the latest build/newest version.

Note:

Our Version Pro tool keeps track of each product you have installed at the GP system level and takes the next step in ensuring that each and every workstation on your network is on the same version for every product. Contact our Sales or Support team for Version Pro registration keys at sales@rocktonsoftware.com or support@rocktonsoftware.com.