Error:

After installing one of our Business Apps. (Recurring Billing, Software Management, Tax Processing) you receive an error similar to the following.

Principal user is missing XXXX privilege.

Cause:

Necessary security has not been given to the user for the Business App. that was installed.

Resolution:

The Business Apps. are tightly integrated with Dynamics 365. Due to this, you will want to be sure you have given users the appropriate security after installing a Business App. in order for the user to continue using Orders, Invoices, etc. If the user is an admin. they should not need additional security.

Review the new roles that have been added for the Business App. in the Security section of the Help files or in the Setup & Configure section within Dynamics 365. Determine the role you wish to add for the user.

  1. Open the User entity under Dynamics 365 | Sales | Settings | Security.
  2. Click Users.
  3. Open the User to whom you wish to assign the role.
  4. Click Manage Roles button.
  5. Mark the role and then click OK.

More Information:

If you do not see the help files when you are in Dynamics 365, follow these steps to add the custom help files.

  1. Open Dynamics 365 System Setting by going to Settings | Administration | System Settings.
  2. From the General tab, scroll to the Set custom Help URL section.
  3. In the Use custom Help for customizable entities field, click Yes.
  4. Click OK.

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