Error: Unhandled script exception: Illegal address for field 'local field' in script 'SetCustomerID'. Script terminated.

Error:

 

The following error message appears when you try to enter or select a Customer ID in the Sales Transaction Entry window:

 

Unhandled script exception: Illegal address for field ‘local field’ in script ‘SetCustomerID’. Script terminated.

 

Cause:

This issue has been documented as a software bug on versions Microsoft Dynamics GP 2015 and GP 2015 R2.

Resolution:

 

Security needs to be changed back to the Microsoft Dynamics GP Sales Transaction Entry and Sales Item Detail Entry windows.

  1. Log into GP as SA or a GP Administrator.
  2. Go to Microsoft Dynamics GP | Tools | Setup | System | Alternate/Modified Forms and Reports.
  3. Select the Alternate/Modified Forms and Reports ID that is assigned to that specific User.

Note: To see what Alternate/Modified Forms and Reports ID is assigned to the User, go to the User Security Setup window (Microsoft Dynamics GP | Tools | Setup | System | User Security).

  1. Then select Omni Price for Product, Windows for Type, and All for Series.
  2. Expand Sales Transaction Entry.
  3. Select Microsoft Dynamics GP.
  4. Repeat Steps 5 and 6 for the Sales Item Detail Entry window.
  5. Click Save.
  6. Have the User log out of GP completely and then log back into GP. The User should no longer receive the error message and Omni Price should still work correctly for them.

Note:

 

Because you no longer have access to the Omni Price alternate window, here is the work around on how to access the Applicable Contracts window:

 

Requirements:

 

  1. You must be on one of these versions of Omni Price or later.
    1. Omni Price for Microsoft Dynamics GP 2013 R2 (12.0.1011)
    2. Omni Price for Microsoft Dynamics GP 2015 and GP 2015 R2 (14.0.4)
    3. Omni Price for Microsoft Dynamics GP 2016 and GP 2016 R2 (16.0.2)
  2. You must have the Allow overriding Contracts during Sales transaction entry option marked in the Pricing Setup window (Microsoft Dynamics GP | Tools | Setup | Omni Price | Pricing Setup).

 

How to access the Applicable Contracts window from a Sales Transaction:

 

  1. Go to Transactions | Sales | Sales Transaction Entry.
  2. Enter a new transaction or select an existing one.
  3. Place your cursor on a line item.
  4. Press CTRL+Y to open the Applicable Contracts window.
  5. Select the Contract ID you would like for the line item.