Error:

When you save an opportunity or quote in Microsoft Dynamics 365, you receive the following message:

Business Process Error msg_RocktonLicense_RocktonLicenseIsInvalid.

Cause:

The registration keys for Rockton Software products expired. The Rockton Essentials product installs when you install one of our Dynamics 365 Business Apps. The Plugins associated with the Rockton Essentials app. are enabled and look for valid registration keys.

Note: This issue is documented as a bug as the plugins should not prevent users from entering an Opportunity or Quote. It will be resolved in a future release.

Resolution:

Resolution 1

If you plan to continue with the product, contact Rockton Software at sales@rocktonsoftware.com for new registration keys. When you receive new registration keys, enter them using the instructions sent from Rockton Software. Then, you may continue using the product.

Resolution 2

If you plan to continue with the product but need to proceed with the transaction before you receive new registration keys, then follow the steps below to disable the plugins. You will be able to save the opportunity or quote after the plugins are disabled.

To Disable the Plugins:

  1. Click Advanced Find.
  2. In the Look For field, select Rockton Licenses.
  3. Click Results.
  4. Open RocktonEssentials License.
  5. In the Disable All Solution Plugins field, click Yes.
  6. Click Save and close the window.

After new registration keys are entered, then re-enable the Plugins:

To Enable the Plugins:

  1. Click Advanced Find.
  2. In the Look For field, select Rockton Licenses.
  3. Click Results.
  4. Open RocktonEssentials License.
  5. In the Disable All Solution Plugins field, click No.
  6. Click Save and close the window.

If you plan to discontinue with the product, you may disable the plugins following the steps in Resolution 1 to allow you to save the opportunity or quote. If you wish to uninstall the product, see KB article: Uninstall a Business App.

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