After installing the latest build of DRM, none of the reports will print

Issue:

 

 

After installing the latest build of Dynamics Report Manager (DRM), none of the reports will print.

 


Cause:

 

In the latest version of DRM, it is a required prerequisite to have Microsoft .NET Framework 4 installed. If it is not installed, the Viewer will not work.

Resolution:

 

Follow these steps to ensure you have Microsoft .NET Framework 4 version or later installed:

 

  1. On the workstation, open Programs and Features.  

     

  2. Under the Name column, look for a program called Microsoft .NET Framework 4 (or higher). Note:  Ensure it is the Microsoft .NET Framework 4 (or higher) Full version and not just the Client Profile or a streamlined installation.

     

  3. If you do not see it in the list of programs, open an Internet Browser search engine and search on: Download Microsoft .NET Framework 4 Full. The results should provide you with a Microsoft link where you download the free program. You may also download it at https://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=17851 assuming this link is still active at the time of this reading. Note: Use caution when downloading the program to ensure it is a safe and reliable source.

     

  4. Once you have downloaded it, run the setup executable (*setup.exe) file to install it. Note:  As part of the installation of the program, you may need to shut down and restart your computer as each system is different.

     

  5. Try printing your report again in DRM.